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The Index lists Help topics available for WinEdit. Use the scroll bar to see entries not currently visible in 
the Help window.
To learn how to use Help, press F1 or choose Using Help from the Help menu.
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WinEdit Keys
Use the following keys in WinEdit:

Moving the Insertion Point
Key(s)                                             Function  
Up Arrow Moves up one line.
Down Arrow Moves down one line.
Right Arrow Moves right one character.
Left Arrow Moves left one character.
Ctrl+Right Arrow Moves right one word.
Ctrl+Left Arrow Moves left one word.
Home Moves to the beginning of the line.
End Moves to the end of the line.
PgUp Moves up one window.
PgDn Moves down one window.
Ctrl+Home Moves to the beginning of the document.
Ctrl+End Moves to the end of the document.

Selecting Text
Key(s)                                             Function  
Shift+Left or Right Arrow Selects text one character at a time to the left or right. Or, if the character

is already selected, cancels the selection.
Shift+Down or Up Selects one line of text up or down. Or, if the line is already selected, 

cancels the selection.
Shift+Home Selects text to the beginning of the line.
Shift+End Selects text to the end of the line.
Ctrl+Shift+Left Arrow Selects the previous word.
Ctrl+Shift+Right Arrow Selects the next word.

Help Keys
Key(s)                                             Function  
F1 WinEdit Help Index
Shift+F1 Extended Help



WinEdit Commands
To get help with a command, choose the appropriate menu:

File Menu Commands
Edit Menu Commands
Search Menu Commands
Run Menu Commands
Window Menu Commands



WinEdit Procedures
To get help with a procedure, choose the appropriate topic:

Changing Printers and Printer Options
Compiling (Running other programs)
Copying, Cutting, and Pasting Text
Creating New Documents
Deleting Text
Extended Help
Finding Text
Printing Documents
Printing Headers and Footers
Reloading Previously Opened Files
Saving Documents
Setting Display Options
Setting Margins
Undo
Using Regular Expressions
WinEdit Project Files
Word Wrap



File Menu Commands
New
Opens a new window with a new, untitled document
Open
Opens a new window with a new, existing document.    WinEdit can read an ASCII text file as large as 
available Windows memory.

Related Topic:
Reloading Previously Opened Files

Save
Saves the current document.    The window remains open.
If the document is UNTITLED, WinEdit prompts you for a document name.
Save As
Saves a document after prompting you for a new name.
Print
Prints the current document using the print settings entered in the Page Setup dialog box.
Page Setup
Allows you to set the margins, headers, footers, printer font, and page layout.
Printer Setup
Sets printer options for WinEdit before printing.
Display Options
Allows you to choose the screen font WinEdit uses, and the tab size.
Exit
Closes all open windows and exits WinEdit.    If there are any unsaved files, WinEdit prompts you before 
exiting.



Edit Menu Commands
Undo
Restores the line the insertion point is on to the same state it was in when the insertion point first moved 
into it.
Cut
Removes the current selection from the document and places it on the clipboard.
Copy
Places a copy of the current selection on the clipboard without removing it from the document.
Paste
Pastes the text in the clipboard into the document at the insertion point.
Delete
Removes the current selection from the document without changing the contents of the clipboard.    If 
there is no selection, removes the character to the right of the insertion point.
Select All
Selects all the text in the document.
Word Wrap
Toggles the word wrap status.    
With word wrap on, WinEdit will wrap the text on screen at an arbitrary 70 character width.    During 
printing, WinEdit will wrap the text to fit between the left and right margins, based on the printer font and 
paper width.
WinEdit places carriage returns in the file only at the point where the ENTER key has been pressed.    
This is the preferred ASCII format for most desktop publishing and word processing programs.



Search Menu Commands
Find
Searches for text in a document.
You can specify these options:
* Find Type the text you want to find.
* Match case Select this box to match the upper and lower case exactly.
* Next Search forward starting at the insertion point.
* Previous Search backward starting at the insertion point.

Repeat Last Find
Repeats the last search using the same options, without opening the Find dialog box.

Change
Searches for text in a document and replaces the found text with text you specify.
You can specify these options:
* Find Type the text you want to find.
* Replace with Type the text you want to insert in place of the found text.
* Match case Select this box to match the upper and lower case exactly.
* Search backwards Search backward starting at the insertion point.
* Confirm before changing When text is found, you will be prompted before the change takes place.
* Change All Start at the beginning of the document, and search the entire document.  

You will be prompted before each change takes place if the Confirm 
before changing box is selected.

Next Error
Prev Error
If any warning or error messages have been captured from the output of one of the Run Menu items, 
these menu choices allow you to review the messages and the corresponding source code.

Related Topic:
Using Regular Expressions



Run Menu Commands
The commands on this menu allow you to run other programs from within WinEdit.    Use the Configure... 
command to enter the necessary command to run the program.
Select the Capture Output box and WinEdit will run the program you configure and save its output.    
When the program finishes, WinEdit will ask if you wish to review any warning or error messages, along 
with the corresponding source code.
WinEdit constructs a batch file to execute from DOS when you choose to capture output.    For this 
reason, when running a Windows application from the Run menu, do not choose to capture the output.

Related Topic:
WinEdit Project Files



Window Menu Commands
Tile
Arranges all open document windows side by side so that all windows are visible.
Cascade
Arranges all open document windows in an overlapping pattern so that the title bar of each window is 
visible.
Arrange Icons
Arranges all document icons into rows.
Close All
Closes all open document windows.    If a document has changes that need saving, you will be prompted 
to save the document before closing.
Document Name
Each open window is listed on the menu by name.    Choose the name and that window will become the 
active document window.



Changing Printers and Printer Options
Select Printer Setup from the File menu to change printer settings.

Select Page Setup from the File menu to change the printer settings for margins, header, footer, printer 
font, and page layout.    WinEdit will remember these settings from session to session.

Related Topic:
Printing Documents
Printing Headers and Footers
Setting Margins



Compiling (Running other programs)
The first four commands on the Run menu are user-configurable commands to execute another program. 
You may configure these commands to execute any .EXE    or .BAT program by typing the command text 
in the appropriate Configure... edit box..
If the program supports DOS redirection (as most compilers and linkers do) you can select the Capture 
Output box to have WinEdit capture the program's output in a file.    When the program has executed, 
WinEdit will allow you to review any messages generated, along with the corresponding source code.
WinEdit constructs a batch file to execute from DOS when you choose to capture output.    For this 
reason, when running a Windows application from the Run menu, do not choose to capture the output.

Related Topic:
WinEdit Project Files



Copying, Cutting, and Pasting Text
To copy and paste, or cut and paste text:
1. Select the text.
2. Choose Copy from the Edit menu to copy the selected text to the clipboard.    Or choose Cut from
the Edit menu to cut the text to the clipboard.
3. Move the insertion point where you want the text to appear.    Or select text you want the pasted 
text to replace.
4. Choose Paste from the Edit menu.

Related Topic:
Deleting Text



Creating New Documents
Choose New from the File menu to open a new, untitled document window.



Deleting Text
To delete text without sending it to the clipboard:
1. Select the text.
2. Choose Delete from the Edit menu or press the Delete key.
If there is no selection, Delete deletes the character to the right of the insertion point.

Related Topic:
Copying, Cutting, and Pasting Text



Extended Help
Press Shift+F1 or click the Right Mouse Button on any Windows SDK function, message, or data 
structure name and WinEdit will access the SDKWIN.HLP topic for that item.

If the word is not a valid Windows SDK topic, WinEdit will pass the word to QH.EXE (Microsoft's 
QuickHelp program, supplied with most Microsoft language products).    This will allow you online access 
to any language or library keyword covered in the QuickHelp database.

For SDK Help, the WinHelp file SDKWIN.HLP must be in either the current directory, the Windows 
directory, or a directory listed in your PATH statement.

For QuickHelp, QH.EXE must be in either the current directory, the Windows directory, or a directory listed
in your PATH statement.    In addition, you must have an environment variable "HELPFILES=" defined 
which tells QH.EXE where to look to find the appropriate QuickHelp database files.



Finding Text
Choose Find from the Search menu to search for text in a document.
You can specify these options:
* Find Type the text you want to find.
* Match case Select this box to match the upper and lower case exactly.
* Next Search forward starting at the insertion point.
* Previous Search backward starting at the insertion point.

Choose Repeat Last Find to repeat the last search using the same options, without opening the Find 
dialog box.

Choose Change to search for text in a document and replace the found text with text you specify.
You can specify these options:
* Find Type the text you want to find.
* Replace with Type the text you want to insert in place of the found text.
* Match case Select this box to match the upper and lower case exactly.
* Search backwards Search backward starting at the insertion point.
* Confirm before changing When text is found, you will be prompted before the change takes place.
* Change All Start at the beginning of the document, and search the entire document.  

You will be prompted before each change takes place if the Confirm 
before changing box is selected.

Related Topic:
Using Regular Expressions



Using Regular Expressions
A regular expression is a search or replace string that uses special characters to match text patterns.    
WinEdit supports UNIX style regular expressions.

When WinEdit conducts a search using regular expressions, it must check character by character in your 
text.    For this reason, searches using regular expressions are slower than regular searches.

The following table describes the regular expression characters recognized by WinEdit.

Expression Description
          \ Escape. WinEdit will ignore any special meaning of the character that 

follows the Escape expression.    Use the Escape if you need to search 
for a literal character that matches a regular expression character.

          . Wild Card. Matches any character.    For example, the expression 'X.X' 
will match 'XaX', 'XbX, and 'XcX', but not 'XaaX'.

          ^ Beginning Of Line. The expression matches only if it occurs at the 
beginning of a line.    For example, '^for' matches the text 'for' only when it
occurs at the beginning of a line.

          $ End Of Line. The expression matches only if it occurs at the end of a line.
For example, '(void)$' matches the text '(void)' only when it occurs at the 
end of a line.

          [ ] Character Class. The expression matches any character in the class 
specified within the brackets.    Use a dash (-) to specify a range of 
character values. For example, '[a-zA-Z0-9]' matches any letter or 
number, and '[xyz]' matches 'x', 'y', or 'z'.

          [ ^ ] Inverse Class. The expression matches any character not specified in 
the class.    For example, '[^a-zA-Z]' matches any character that is not a 
letter.

          * Repeat Operator. Matches zero or more occurences of the character that
precedes the '*'.    For example, 'XY*X' matches 'XX', 'XYX', and 'XYYX.

          + Repeat Operator. Matches one or more occurences of the character that 
precedes the '+'.    For example, 'XY+X' matches 'XYX' and 'XYYX, but 
not 'XX'.

Related Topic:
Finding Text



Printing Documents
Choose Print from the File menu to send the current document to the printer.

Related Topic:
Changing Printers and Printer Options
Printing Headers and Footers
Setting Margins



Printing Headers and Footers
Choose Page Setup from the File menu to configure header and footer text.    Type the text you wish to 
appear at the top and bottom of each page.

You can use the following special characters in headers and footers:
* %f The document name will appear.
* %d The date and time of the printout will appear.
* %p The page number will appear.

Related Topic:
Changing Printers and Printer Options
Printing Documents
Setting Margins



Reloading Previously Opened Files
WinEdit automatically reloads the file you were last working with by saving the name of the active file 
when you quit.

You can also specify a file named "LASTFILE.ED" as the command line argument and WinEdit will ignore 
the command line and will still reload the last file you were working on.

The reason you may want to specify "LASTFILE.ED" is because it is not possible to specify a startup 
directory for Program Items in Program Manager.    And if you are using WinEdit on a particular project 
whose files are in one directory, you would have to use the File Open... dialog box every time you start to 
switch to that directory.

Here's how you can get around this with WinEdit:

1. Create a file named "LASTFILE.ED" in the directory you wish to be the startup directory.    Or copy
the file by that name included with WinEdit to that directory.

2. Associate ".Ed" files with WinEdit by selecting that file in File Manager and choosing 
"Associate..." from File Manager's File menu.

3. Create a Program Item with the complete pathname to that file. For example, if your project is in 
"D:\NEWPROG", create a Program Item for "D:\NEWPROG\LASTFILE.ED".

Program Manager will use the "DOS" icon by default, but you can override this by using "WINEDIT.EXE" 
as the program name in the "CHANGE ICON" dialog box.    You'll get the WinEdit icon in your Program 
Group, "D:\NEWPROG" will be your current directory, and WinEdit will start up with the same file you 
were editing when you last used WinEdit.

Of course, an easier way to accomplish the directory change might be to use Wilson WindowWare's 
Command Post instead of Program Manager.



Saving Documents
Choose Save from the File menu to save a document.    Choose Save As to save the document with a 
new name, or to save an untitled document.



Setting Display Options
Choose Display Options from the File menu to choose a screen font and default tab size.



Setting Margins
Choose Page Setup from the File menu to change the margins used for printouts.    You can enter the 
measurements for top, bottom, left, and right margins.
The margin settings are in inches or centimeters, corresponding to the English or Metric Measurement 
setting in Control Panel.

Related Topic:
Changing Printers and Printer Options
Printing Documents
Printing Headers and Footers



Undo
Choose Undo from the Edit menu to restore the current line to the state it was when the insertion point 
was first moved in to it.



WinEdit Project Files
WinEdit saves the information from the Configure... dialog box in a private INI file with an extension of
.WPJ (WinEdit Project File).    Choose the Save... pushbutton to save the contents of the dialog box in 
a .WPJ file.    Choose the Open... pushbutton to load an existing .WPJ file.



Word Wrap
Choose Word Wrap from the Edit menu to toggle the word wrap status.
With word wrap on, WinEdit will wrap the text on screen at an arbitrary 70 character width.    During 
printing, WinEdit will wrap the text to fit between the left and right margins, based on the printer font and 
paper width.
WinEdit places carriage returns in the file only at the point where the ENTER key has been pressed.    
This is the preferred ASCII format for most desktop publishing and word processing programs.

Related Topic:
Changing Printers and Printer Options
Printing Documents
Setting Margins




